Author Topic: V. 2.0 for 1.1 RC2  (Read 6163 times)

Offline Auto Surf Extreme

V. 2.0 for 1.1 RC2
« on: January 03, 2006, 06:23:13 am »
Hello Daniel,

Using the update 1.31 ~ 2.0 I'm getting these errors is this a major undertaking to get V.2.0 to run on rc2 ?

I'm using the default template with the tabs.



Installing this package will perform the following actions:
   Type    Action    Description
1.    Extract File    ./Sources/shop/ShopAdmin.php    
2.    Extract File    ./Sources/shop/Shop.php    
3.    Extract File    Themes/default/Shop.template.php    
4.    Extract File    Themes/default/ShopAdmin.template.php    
5.    Extract File    Themes/default/languages/Shop.english.php    
6.    Extract File    ./Sources/shop/items/EmailAdmin.php    
7.    Execute Modification    ./index.php    Test failed
8.    Execute Modification    ./Sources/RemoveTopic.php    Test successful
9.    Execute Modification    ./Sources/Subs.php    Test failed
10.    Execute Modification    ./Themes/default/index.template.php    Test failed
11.    Execute Code    updateScript.php

Offline Daniel15

Re: V. 2.0 for 1.1 RC2
« Reply #1 on: January 03, 2006, 06:33:13 am »
I haven't yet tested SMFShop on SMF 1.1RC2, so I can't comment. Try setting up a test installation of SMF 1.1RC2, and then try to install SMFShop. DON'T install it on a live board, as it isn't tested on SMF 1.1RC2!!
I'll set up a testing installation tonight (it's 9:31AM at the moment), and see how it goes.

Andy

  • Guest
Re: V. 2.0 for 1.1 RC2
« Reply #2 on: January 03, 2006, 06:39:50 pm »
Hey Daniel, is it working on RC2? =/

Offline Daniel15

Re: V. 2.0 for 1.1 RC2
« Reply #3 on: January 03, 2006, 08:19:54 pm »
Sorry, haven't tested it yet.

I've been really busy with other projects.

Andy

  • Guest
Re: V. 2.0 for 1.1 RC2
« Reply #4 on: January 03, 2006, 08:20:25 pm »
Understandable.

Andy

  • Guest
Re: V. 2.0 for 1.1 RC2
« Reply #5 on: January 04, 2006, 07:58:58 pm »
SMF Shop 2.0 DOES work for SMF 1.1 RC2!

Offline Daniel15

Re: V. 2.0 for 1.1 RC2
« Reply #6 on: January 04, 2006, 08:30:54 pm »
Yes, it does now :D
I updated the install package so it adds a 'Shop' tab (that's the only thing that the package didn't do previously). You can get the new package from my site at http://www.dansoftaustralia.net/

Offline Auto Surf Extreme

Re: V. 2.0 for 1.1 RC2
« Reply #7 on: January 05, 2006, 12:31:27 pm »
Well I think I messed up. So frustrating, I could'nt get 2.0 to update my 1.31 on RC2 so I tried removing all reffrances to Shop Mod including the SQL tables.

Now I can get shop mod 2.0 to install fine, but... You can only see it in the admin section and I'm getting tons of database errors. It looks like it did not re-install the SQL tables.


Table 'talkauto_tas.smf_shop_inventory' doesn't exist
File: /home/talkauto/public_html/Sources/shop/Shop.php
Line: 702

Adding an item:

Table 'talkauto_tas.smf_shop_items' doesn't exist
File: /home/talkauto/public_html/Sources/shop/ShopAdmin.php
Line: 231


Restocking:

Table 'talkauto_tas.smf_shop_items' doesn't exist
File: /home/talkauto/public_html/Sources/Load.php(1610) : eval()'d code
Line: 207

ect ect. Any Ideas?

Offline Daniel15

Re: V. 2.0 for 1.1 RC2
« Reply #8 on: January 05, 2006, 01:53:55 pm »
First, remove ALL references to the shop in the MySQL database. That includes the shop_items and shop_inventory tables (it seems that you've already done that). You'll also need to remove:

 * the money and moneyBank fields in smf_members
 * every shop entries in the shop_settings table (shopVersion, shopBuild, shopCurrencyPrefix, etc...)
 * the countCredits (or similar, can't remember at the moment) field from the boards table

Next, unarchive the shop tar.gz file. Put the installScript.php file in your forum's directory, and run it.

Mattitude

  • Guest
Re: V. 2.0 for 1.1 RC2
« Reply #9 on: January 28, 2006, 07:43:01 pm »
Unfortunately the php file isn't working for me - could you please provide me with a sql file to do it in PHPMyAdmin instead please? prefix smf_

Offline Daniel15

Re: V. 2.0 for 1.1 RC2
« Reply #10 on: January 28, 2006, 08:29:15 pm »
Why doesn't the PHP file work for you? What error do you get?

Otherwise, all the SQL queries are run from inside the PHP file. I'm sure you'd be able to grab the SQL queries from it (and obviously replace {$db_prefix} with the prefix). If not, I'll get all the queries tommorow (it's getting late here now).

Mattitude

  • Guest
Re: V. 2.0 for 1.1 RC2
« Reply #11 on: January 28, 2006, 08:43:24 pm »
Fair enough - don't get an error at all, it just doesn't do a thing - yeah I'll do that then, I just thought maybe you had a sql file to hand (as that would have been easier) - no problem.